We do .Net 4.0 version

Mar 12, 2011 at 8:30 AM
Edited Mar 12, 2011 at 8:30 AM

We are using .net 4 framework, and as I see that u have not upgraded to .net 4 version yet, is this right. If not when will be a .net 4 version?

 

Coordinator
Mar 12, 2011 at 9:38 AM

That is no problem at all! Catel is designed to work with .NET framework 4.0 as well. However, we didn't want to exlcude the 3.5 SP1 users (some companies are not ready to upgrade to 4.0 yet). Simply reference the 3.5 libraries of Catel and all should work fine.

The only additional library that *might* be required is the WPFToolkit.

If people really want a 4.0 version, you can create an issue and we might consider creating a 4.0 library of both the Core and Windows project with the same files.

Coordinator
Mar 12, 2011 at 9:52 AM

As an update: in the latest source, we have removed the Jetpack theme because it was not working and required a reference to the WPFToolkit (although the theme was not being used in a .NET app).