Catel - Nuget problem

Oct 14, 2011 at 12:18 PM

I created a new Silverligh 4 solution and am using Nuget to configure it for Catel, using the Microsoft Package Manager (In the extension manager it only finds one reference to Catel 2.1).

Catel.Core installed just fine. Catel.Silverlight on the other hand results in an error:

PM> Install-Package Catel.Silverlight

'SilverlightToolkit-Core (≥ 4.2010.4)' not installed. Attempting to retrieve dependency from source...


Successfully installed 'SilverlightToolkit-Core 4.2010.4'.

Successfully installed 'Catel.Silverlight 2.2'.

Installing code snippets for Visual Studio 2005

Installing code snippets for Visual Studio 2010

Install failed. Rolling back...

Install-Package : Unable to find assembly references that are compatible with the target framework '.NETFramework,Version=v4.0'.

At line:1 char:16

+ Install-Package <<<< Catel.Silverlight

+ CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException

+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand

Oct 14, 2011 at 12:45 PM

First, let's make some assumptions. If one is wrong, please let me know.

1) Catel.Core is installed to the server side (.NET 4.0 project)

2) Catel.Silverlight is installed to the client (Silverlight 4 project)


It looks like it fails to copy the code snippets, but that is strange because exactly the same script is used for Catel.Core. The only thing I can imagine is that VS2010 somehow locks the code snippets and therefore the powershell script inside the nuget package cannot install the code snippets, but I have never seen this before.

Have you tried installing the Catel.Silverlight package without installing the Catel.Core project? Does it give you the same error?

Oct 14, 2011 at 12:51 PM

I am kind of stuck for the moment. I updated my Nuget to the lastes version 1.5.20902.9026 and now get "Unable to connect to the remote server".

So what you are saying is that I need to install Catel.Core in the website project that is hosting my SL and that only Catel.Silverlight  needs to be installed  in my SL project?


Oct 14, 2011 at 1:00 PM

Strange, seems like nuget is failing at the moment.

You indeed need to install Catel.Core to the website proejct, and Catel.Silverlight on the SL project. we are looking to support only one nuget package, but then you can't retrieve Catel.Core separately any longer...

Oct 14, 2011 at 1:03 PM

Do you mean that you also can't connect to nuget at the moment?

Oct 15, 2011 at 6:34 AM

No, it was a more general mention in "if you get a unable to connect to the remote server", it probably is your company's firewall or something like that.