EventToCommand is built in SL4?

May 22, 2012 at 12:19 PM

Environment: VS11 beta, Project in SL5, Catel 3.1

When I want to use  EventToCommand, VS show me:

 The type “EventToCommand” in assembly “Catel.MVVM” is built by an old version of Blend SDK, and is not supported in Silverlight 5 project.

I changed the Microsoft.Expression.Interactions.dll and System.Windows.Interactivity.dll referenced by my project from TargetFramework 4.0 to TargetFramework 5.0. But VS still show me that error.

So, what should i do?

May 22, 2012 at 12:24 PM

Interesting, we probably built the EventToCommand with an old System.Windows.Interactivity. Unfortunately, I don't have access to the new files right now, so if you could upload them, I will replace them in 3.2.

May 22, 2012 at 12:33 PM

Upload the file using Issue Tracker?

Sorry, it's the first time to do that for me. I hope I'm right: http://catel.codeplex.com/workitem/7137

May 22, 2012 at 12:38 PM

Excellent, thanks!